Ubuntu Hardy 64bit + pptpconfig (amd64 architecture)


Hallo,

habe gerade versucht pptpconfig unter Ubuntu Hardy zu installieren. Dieses Programm bietet ein GUI zur Erstellung von VPN-Verbindungen.

Laut dem Wiki muss man folgende Quelle in die Datei /etc/apt/sources.list hinzufügen:

deb http://quozl.linux.org.au/pptp/pptpconfig ./

Danach kann man über sudo apt-get update && sudo apt-get install pptpconfig dieses Programm installieren. Bei mir kam jedoch eine Fehlermeldung, dass ein paar benötigte Pakete nicht in den Paketquellen erhalten wären. Das Problem lag darin, dass ich mit meiner 64bit-Version die amd64-Architektur habe und in den Paketquellen für pptpconfig nur Pakete für i386 vorhanden sind.

Die Lösung sieht daher folgendermaßen aus:

Es gibt für die nötigen Pakete RPM-Pakete zum Runterladen bei Sourceforge. Ich habe folgende RPMs runtergeladen:

Wenn diese Dateien auf den Desktop heruntergeladen sind folgende Befehle ausführen:

$ sudo apt-get install alien (dieses Programm ermöglicht die Umwandlung von RPM nach DEB)
$ sudo alien php4-pcntl-gtk-1.0.2-2×86_64.rpm
$ sudo alien php4-pcntl-4.4.1-2.x86_64.rpm
$ sudo alien php-pcntl-4.4.1-1.x86_64.rpm

Nun liegen 3 .deb-Pakete am Desktop. Diese lassen sich einzeln nach einem Doppelklick installieren.

Ist das erstmal erledigt, läßt sich pptpconfig problemlos über

$ sudo apt-get install pptpconfig

installieren.

R.S.

Advertisements

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s